Resource icon

Resource Hyper Training Script

Jonas930

Is anyonre there?
Member
Joined
Apr 15, 2017
Posts
102
Jonas930 submitted a new resource:

Hyper Training Script - Make your game have gen 7-ish function!!

THIS IS FOR CLEAR ESSENTIALS V17.2. DIDN'T TEST ON OLDER VERSION OR WITH EBS.

This is the SIMPLE script that can make Hyper Training to appear in your game.

Installation:
Now it is the simplest Plug-and-Play script which not really need any skill or knowledge for coding. Just follow steps by steps, then you and your game will be fine.
  1. Open...

Read more about this resource...
 

Morningdew

Novice
Member
Joined
Jul 8, 2017
Posts
26
It works pretty well, but I am getting a few errors.

When the egg is in one of the first 5 slots in the party, and I select the egg in the menu, it selects the next Mon to be trained. I know I shouldn't select an egg, but it is still glitched.

With the egg in the 6th slot, I got this error:

---------------------------
Pokemon Essentials
---------------------------
[Pokémon Essentials version 17.2]
Exception: RuntimeError
Message: Script error within event 7 (coords 5,9), map 2 (Lappet Town):
Exception: NoMethodError
Message: pbMrHyper:21:in `pbMrHyper'undefined method `egg?' for nil:NilClass
***Full script:
pbMrHyper(:STARDUST,:STARPIECE)

Interpreter:243:in `pbExecuteScript'
(eval):1:in `pbExecuteScript'
Interpreter:1606:in `eval'
Interpreter:243:in `pbExecuteScript'
Interpreter:1606:in `command_355'
Interpreter:494:in `execute_command'
Interpreter:193:in `update'
Interpreter:106:in `loop'
Interpreter:198:in `update'
Scene_Map:163:in `follow_update'

Interpreter:276:in `pbExecuteScript'
Interpreter:1606:in `command_355'
Interpreter:494:in `execute_command'
Interpreter:193:in `update'
Interpreter:106:in `loop'
Interpreter:198:in `update'
Scene_Map:163:in `follow_update'
Scene_Map:161:in `loop'
Scene_Map:170:in `follow_update'
Followers:1551:in `update'
 

EpiQ

Novice
Member
Joined
Mar 1, 2018
Posts
22
Tested with EBS and working well!!:blush:
But with egg I have same error like Morningdew.
 

Jonas930

Is anyonre there?
Member
Joined
Apr 15, 2017
Posts
102
It works pretty well, but I am getting a few errors.

When the egg is in one of the first 5 slots in the party, and I select the egg in the menu, it selects the next Mon to be trained. I know I shouldn't select an egg, but it is still glitched.

With the egg in the 6th slot, I got this error:

---------------------------
Pokemon Essentials
---------------------------
[Pokémon Essentials version 17.2]
Exception: RuntimeError
Message: Script error within event 7 (coords 5,9), map 2 (Lappet Town):
Exception: NoMethodError
Message: pbMrHyper:21:in `pbMrHyper'undefined method `egg?' for nil:NilClass
***Full script:
pbMrHyper(:STARDUST,:STARPIECE)

Interpreter:243:in `pbExecuteScript'
(eval):1:in `pbExecuteScript'
Interpreter:1606:in `eval'
Interpreter:243:in `pbExecuteScript'
Interpreter:1606:in `command_355'
Interpreter:494:in `execute_command'
Interpreter:193:in `update'
Interpreter:106:in `loop'
Interpreter:198:in `update'
Scene_Map:163:in `follow_update'

Interpreter:276:in `pbExecuteScript'
Interpreter:1606:in `command_355'
Interpreter:494:in `execute_command'
Interpreter:193:in `update'
Interpreter:106:in `loop'
Interpreter:198:in `update'
Scene_Map:163:in `follow_update'
Scene_Map:161:in `loop'
Scene_Map:170:in `follow_update'
Followers:1551:in `update'

Tested with EBS and working well!!:blush:
But with egg I have same error like Morningdew.


Now it should work with eggs.
Tbh, I really forgot egg is a thing. :joy:
 

Morningdew

Novice
Member
Joined
Jul 8, 2017
Posts
26
Now it should work with eggs.
Tbh, I really forgot egg is a thing. :joy:

The egg part is fixed now, which works great! However, selecting the last Pokemon in your party to Hyper Train still gives this error... :(

---------------------------
Pokemon Essentials
---------------------------
[Pokémon Essentials version 17.2]
Exception: RuntimeError
Message: Script error within event 7 (coords 5,9), map 2 (Lappet Town):
Exception: NoMethodError
Message: pbMrHyper:24:in `pbMrHyper'undefined method `level' for nil:NilClass
***Full script:
pbMrHyper(:STARDUST,:STARPIECE)

Interpreter:243:in `pbExecuteScript'
(eval):1:in `pbExecuteScript'
Interpreter:1606:in `eval'
Interpreter:243:in `pbExecuteScript'
Interpreter:1606:in `command_355'
Interpreter:494:in `execute_command'
Interpreter:193:in `update'
Interpreter:106:in `loop'
Interpreter:198:in `update'
Scene_Map:163:in `update'

Interpreter:276:in `pbExecuteScript'
Interpreter:1606:in `command_355'
Interpreter:494:in `execute_command'
Interpreter:193:in `update'
Interpreter:106:in `loop'
Interpreter:198:in `update'
Scene_Map:163:in `update'
Scene_Map:161:in `loop'
Scene_Map:170:in `update'
Scene_Map:234:in `main'
 

Jonas930

Is anyonre there?
Member
Joined
Apr 15, 2017
Posts
102
The egg part is fixed now, which works great! However, selecting the last Pokemon in your party to Hyper Train still gives this error... :(

---------------------------
Pokemon Essentials
---------------------------
[Pokémon Essentials version 17.2]
Exception: RuntimeError
Message: Script error within event 7 (coords 5,9), map 2 (Lappet Town):
Exception: NoMethodError
Message: pbMrHyper:24:in `pbMrHyper'undefined method `level' for nil:NilClass
***Full script:
pbMrHyper(:STARDUST,:STARPIECE)

Interpreter:243:in `pbExecuteScript'
(eval):1:in `pbExecuteScript'
Interpreter:1606:in `eval'
Interpreter:243:in `pbExecuteScript'
Interpreter:1606:in `command_355'
Interpreter:494:in `execute_command'
Interpreter:193:in `update'
Interpreter:106:in `loop'
Interpreter:198:in `update'
Scene_Map:163:in `update'

Interpreter:276:in `pbExecuteScript'
Interpreter:1606:in `command_355'
Interpreter:494:in `execute_command'
Interpreter:193:in `update'
Interpreter:106:in `loop'
Interpreter:198:in `update'
Scene_Map:163:in `update'
Scene_Map:161:in `loop'
Scene_Map:170:in `update'
Scene_Map:234:in `main'

Hmm... that is weird because I didnt got any error when i choose last or sixth pokemon. :neutral:
 

Nebby

Rookie
Member
Joined
Jul 2, 2017
Posts
8
I installed this back when this first got released, and it worked fine upon installation!


Say, I did see an NCP that also read the Pokémon's IV's. Is that a part of a different resource?
 
Top